Логотип
Надстройка VBA-Excel
Благодарю за столь полезную подборку нужных инструментов, желаю успехов в развитии!
Александр Зуев

Как отобразить текст и число в одной ячейке

Иногда необходимо указывать в одной ячейке текст и значение. Например, в конце таблицы с товарами указать "Итого: 123,45". В Excel это можно сделать несколькими способами.

 

Скачать файл!

Создан:    17.06.2017

 Скачан:    8

Для того чтобы в одной ячейке совместить как текст так и значение можно использовать следующие способы:

  • Конкатенация;
  • Функция СЦЕПИТЬ;
  • Функция ТЕКСТ;
  • Пользовательский формат.

Разберем эти способы и рассмотрим плюсы и минусы каждого из них.

Использование конкатенации

Один из самых простых способов реализовать сочетание текста и значения - использовать конкатенацию (символ &).

Допустим ячейка A1 содержит итоговое значение 123,45, тогда в любой другой ячейке можно записать формулу
="Итого: "&A1

В итоге результатом будет следующее содержание ячейки Итого: 123,45.

Это простое решение, однако имеет много минусов. 

  1. Результатом формулы будет текстовое значение, которое нельзя будет использовать при дальнейших вычислениях.
  2.  Значение ячейки A1 будет выводится в общем формате, без возможности всякого форматирования. В следствие чего этот метод не всегда применим.

Применение конкатенации в Excel

Применение функции СЦЕПИТЬ

Аналогичное простое решение, но с теми же недостатками  - использование функции СЦЕПИТЬ. Применяется она так: =СЦЕПИТЬ("Итого: ";A1). Результаты ее использования аналогичные:

Использование функции СЦЕПИТЬ

Применение функции ТЕКСТ

Функция ТЕКСТ позволяет не только объединить текст и значение, но еще и отформатировать значение в нужном формате. Если мы применим следующую формулу =ТЕКСТ(A1;"""Итого: ""##0"), то мы получим такой результат Итого: 123.

В качестве второго аргумента функция ТЕКСТ принимает строку с числовым форматом. Более подробно о числовых форматах вы можете прочитать в статье Применение пользовательских форматов.

Функция Текст

Единственный минус этого способа в том, что полученные значения также являются текстовыми и с ними нельзя проводить дальнейшие вычисления.

Использование пользовательского формата

Не такой простой способ как предыдущие, но наиболее функциональный. Заключается в применении к итоговой ячейки пользовательского числового формата. Чтобы добавить текст "Итого" к ячейке A1 необходимы следующие действия:

  1.  Выберите ячейку A1.
  2. Откройте диалоговое окно Формат ячейки.
    Вызов Формата ячейки
  3. В поле Тип укажите нужный формат. В нашем случае "Итого: "# ##0.
    Использование пользовательского формата

В результате ячейка A1 будет содержать Итого: 123.

Большой плюс данного способа заключается в том, что вы можете использовать в дальнейших вычислениях ячейку A1 так же как и число, но при этом отображаться она будет в нужном вам виде. 

Плюсы и минусы методов

В таблице далее сведены плюсы и минусы. В зависимости от ситуации можно пользоваться тем или иным способом обращая на особенности каждого.

Плюсы и минусы методов

Ссылки по теме

  1. Применение пользовательских форматов

Комментарии:

comments powered by Disqus