Логотип
Надстройка VBA-Excel
Один из самых лучших продуктов по цена/качество. Подробнейшие инструкции, поймут все кто даже только открыл для себя Excel.
Сергей

Определение номера квартала по дате

Удобная формула НОМКВАРТАЛА для вычисления номера квартала по дате в Excel.

 

Добавить в Excel!

Установите программу

*Этого функционала нет в стандартном Excel

 Скачали:  29 436 чел.

Описание работы

Функция =НОМКВАРТАЛА служит для определения номера квартала по дате. Можно, конечно, ограничиться стандартными функциями Excel. Сочетание формул ЕСЛИ и МЕСЯЦ также решит эту задачу. Формула получается достаточно громоздкая, а пользовательская функция на VBA проста и понятна.

Стандартными методами проблема решается такой формулой:

=ЕСЛИ(МЕСЯЦ(A1)<4;1;ЕСЛИ(МЕСЯЦ(A1)<7;2;ЕСЛИ(МЕСЯЦ(A1)<10;3;4)))

Синтаксис

Функция =НОМКВАРТАЛА(ДАТА) имеет всего один аргумент:

  • ДАТА - Дата, номер квартала которой необходимо определить.

Пример

Определение номера квартала по дате

Код на VBA

Function НОМКВАРТАЛА(ByVal ДАТА As Date) As Integer
    Dim m As Integer
    m = Month(ДАТА)
    Select Case m
        Case 1 To 3
            НОМКВАРТАЛА = 1
        Case 4 To 6
            НОМКВАРТАЛА = 2
        Case 7 To 9
            НОМКВАРТАЛА = 3
        Case Else
            НОМКВАРТАЛА = 4
    End Select
End Function

Установка

Обращаем Ваше внимание, что функционал, описанный в данной статье, ОТСУТСТВУЕТ в Excel.

Чтобы его добавить, необходимо установить надстройку VBA-Excel. Данная программа содержит более сотни функций, которые сделают работу с Excel в разы эффективней. С ней рутинные задачи будут занимать считанные секунды. Программой уже воспользовались 29 436 чел., попробуйте и Вы!


Установите программу

Ссылки по теме

  1. Как определить день недели по дате в Excel
  2. Найти дату в тексте ячейки Excel
  3. Дата прописью в Excel, как преобразовать дату в текст

Комментарии:

comments powered by Disqus