Логотип
Надстройка VBA-Excel
Надстройка хорошая. С нетерпением ждем обновления.
Сергей

Расчет отпускных дней в Excel

Когда работаешь в компании не первый год, то начинаешь забывать сколько еще осталось неотгуленного отпуска. Поэтому сделал небольшой калькулятор количества дней отпуска в Excel.

 

Скачать файл!

Создан:    19.04.2014

 Скачан:    3835

Как пользоваться калькулятором отпускных дней

Пользоваться калькулятором достаточно просто.  Расчет сделан в привычной для многих программе Excel. 

Все что нужно для расчета отпуска - это:

  1. Указать дату трудоустройства;
  2. Отметить свои предыдущие дни отпуска. 

Excel автоматически рассчитает количество начисленного и отгуленного отпуска, а также покажет сколько еще положено отпускных дней на текущую дату.

Вы можете просто скачать файл (разобраться в нем не составит труда) или дочитать статью до конца и понять как его сделать самостоятельно.

Как сделать калькулятор самостоятельно

Для начала надо вспомнить дату трудоустройства. Ее можно найти в трудовой книжке или спросить в бухгалтерии.

Далее нам потребуется текущая дата.  Чтобы не указывать ее каждый раз при открытии файла, можно воспользоваться формулой =СЕГОДНЯ()

Теперь посчитаем количество отпускных дней с начала трудоустройства. Так как в год нам положено 28 календарных дней, то посчитаем количество отработанных дней поделим на 365. Для этого введем следующую формулу
=ОКРУГЛ((C4-C3)/365*28;0). Я дополнительно округлил полученное число до целых.

Дальше самое сложное - это вспомнить сколько дней уже было отгулено. Для этого я сделал "умную" таблицу Журнал отпусков, в которой будем отмечать все наши отпуска. В этой таблице необходимо заполнять начало и конец отпуска. Календарные дни почитаются автоматически по формуле =[@Конец]-[@Начало]+1.

Если в отпуск вошли праздничные дни, то их нужно исключить, так как они не учитываются при расчете отпускных дней. Отметьте их количество в столбце Праздничные дни. Количество отгкленных дней необходимо посчитать по следующей формуле =[@[Календарные дни]]-[@[Праздничные дни]].

Складываем все отгуленные дни. В ячейке C6 используем для этого такую формулу: =СУММ(Журнал[Отгуленные дни]).

Осталось в ячейке C8 вычесть из общего количества начисленного отпуска сумму отгуленного отпуска по формуле =C5-C6. Вот и все, мы посчитали количество оставшегося отпуска на текущую дату. Теперь вы всегда будете знать сколько отпуска вам осталось. При открытие файла, Excel автоматически будет обновлять все данные.

Ссылки по теме

  1. Создание календаря в Excel на год

Комментарии:

comments powered by Disqus